This is the 15th day of my participation in Gwen Challenge

Static linked lists – that is, using arrays to store linked lists.

1032 Sharing (25 分) To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification: Each input file contains one test case. For each case, The first line contains two addresses of nodes and a positive N (≤10 5), where the two addresses are the addresses of the first nodes of the two words, N is the total number of nodes. The address of a node is a 5-digit positive INTEGER, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification: For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1: 11111 22222 9 67890 i 00002 00010 a 12345 00003 g -1 12345 D 67890 00002 n 00003 22222 B 23456 11111 L 00001 23456 e 67890 00001 o 00010 Sample Output 1: 67890 Sample Input 2: 00001 00002 4 00001 a 10001 10001 s -1 00002 a 10002 10002 t -1 Sample Output 2: -1

#include <cstdio>
#include <cstring>
const int MAXSIZE = 100010;
struct NODE{
    char data;
    int next;
    bool flag;
}node[MAXSIZE];

int main(a){
    int worda, wordb, total;
    scanf("%d%d%d",&worda, &wordb, &total);
    int Add,TemData,NextTem;
    for(int i = 0; i<total; ++i){
        scanf("%d %c %d",&Add, &TemData, &NextTem);
        node[Add].data = TemData;
        node[Add].next = NextTem;
        node[Add].flag = 0;
    }
    int j = worda;
    while(j ! =- 1){
        node[j].flag = 1;
        j = node[j].next;
    }
    int t = wordb;
    while(t! =- 1) {if(node[t].flag){
            printf("%05d\n",t);
            return 0;
        }
        t = node[t].next;
    }
    printf("-1\n");
    return 0;
}
Copy the code

1052 Linked List Sorting (25) A Linked List consists of A series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification: Each input file contains one test case. For each case, the first line contains a positive N (<10 5 ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is Represented by – 1.

Then N lines follow, each describes a node in the format:

Address Key Next where Address is the Address of the node in memory, Key is an integer in [−10 5,10 5], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification: For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input: 5 00001 11111 100 -1 00001 0 22222 33333 100000 11111 12345 -1 33333 22222 1000 12345 Sample Output: 5 12345 12345-1 00001 00001 0 11111 11111 100 22222 22222 1000 33333 33333 100,000-1

#include <cstdio>
#include <algorithm>
using namespace std;
const int MAXSIZE = 100005;
struct NODE{
    int address;
    int data;
    int next;
    bool flag;// Check whether it is on the linked list.
}node[MAXSIZE];

bool cmp(NODE a, NODE b){
    if(a.flag==false || b.flag==false) {return a.flag >b.flag;
    } else {
        returna.data < b.data; }}int main(a){
    int total,addf;
    scanf("%d%d",&total,&addf);
    int addT, dataT, nextT;
    for(int i = 0; i< MAXSIZE; i++){ node[i].flag =false;
    }
    for(int i = 0; i < total; i++){scanf("%d%d%d",&addT, &dataT, &nextT);
        node[addT].address = addT;
        node[addT].data = dataT;
        node[addT].next = nextT;
        //next[addT].flag = true;
        // Invalid nodes may occur
    }
    int count = 0, p = addf;
    while(p ! =- 1){
        node[p].flag = true;
        count++;
        p = node[p].next;
    }

    if(count == 0) {printf("0-1");
    } else {
        sort(node, node+MAXSIZE,cmp);
        printf("%d %05d\n", count, node[0].address);
        for(int i = 0; i < count ; i++){if(i ! = count- 1) {printf("%05d %d %05d\n",node[i].address,node[i].data,node[i+1].address);
            } else {
                printf("%05d %d -1\n",node[i].address,node[i].data); }}}return 0;
}
Copy the code

Thinking and summarizing

When doing the problem to choose a static list lion ah is a must learn small skills, the array is simple, the list of all kinds of complex operations are simplified, traversal time will be constant, simply can’t be great!

There are a few things to note when creating static lists:

  1. Confirm the starting point, because the establishment of static linked list is generally to solve practical problems, so at this time, in fact, you can take out the first node to record the number of summary points, so as to ensure logical fluency, reduce +1, -1 operations.

  2. Note the space constraints of the problem. Using a static list requires a lot of space.